Agresso - Intermittent Authentication Issues
Resolved
Jul 17 at 04:00pm BST
We are removing the degraded status from the Business World (Agresso) service, as the intermittent authentication issue no longer appears to be affecting users.
We will continue to monitor the service closely and re-escalate if necessary.
Affected services
Business World (Agresso)
Updated
Jul 17 at 11:00am BST
We are continuing to investigate the intermittent authentication issues affecting Agresso. While there is no change in status at this time, please be assured that resolving the issue remains a priority. We will share further updates as soon as new information becomes available.
Affected services
Business World (Agresso)
Created
Jul 04 at 10:50am BST
We are investigating an intermittent issue affecting signing in to Business World (Agresso).
Please try signing in again, or close and re-open your browser, as it should then allow you to access Agresso normally.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Business World (Agresso)